CloverOS CloverOS support and anything CloverOS-related.

Features and wishlist
1 2 »
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Features and wishlist
#1
List things you want added, changed or removed from the distro in order to improve CloverOS. So far everything has worked well for me on each of my thinkpads and desktops, but what are some edge cases that you want highlighted? Remember it has to fall in line with the distros current philosophy and be able to be compiled via ebuild.
T61 X9000 8gb 1680x1050
W500 X9100 8gb(dead)
T410 i7-640M 8gb 1440x900
T420 i7-2820QM 8gb 1920x1080
X230t i7-3520M 8gb 1336x768
W530 i7-3920XM 32gb 1920x1080
T440p i7-4810QM 8gb 1920x1080
W541 i7-4940XM 32gb 1920x1080

Reply
#2
i want a gf simulator

Reply
#3
The todo list is in: https://gitgud.io/cloveros/cloveros/blob/master/notes

Reply
#4
(03-24-2019, 11:11 AM)cloveros Wrote: The todo list is in: https://gitgud.io/cloveros/cloveros/blob/master/notes

Good stuff, just making a thread so others can make suggestions as well

(03-24-2019, 05:44 AM)mistertim Wrote: i want a gf simulator

install wine, then play any gf simulator available on the internet
T61 X9000 8gb 1680x1050
W500 X9100 8gb(dead)
T410 i7-640M 8gb 1440x900
T420 i7-2820QM 8gb 1920x1080
X230t i7-3520M 8gb 1336x768
W530 i7-3920XM 32gb 1920x1080
T440p i7-4810QM 8gb 1920x1080
W541 i7-4940XM 32gb 1920x1080

Reply
#5
DragonflyBSD kernel option.
It will acheive greatness maybesoon.

Reply
#6
I'll add to this:

--Detailed guide on converting from binary-clover to source; Changing this in cloveros_settings on a default install is one thing, but on a default install, updating the world set (Emerge -uavD @World) after changing from binary to source, results in multiple perl-related errors/slot conflicts within portage, making it an uphill struggle for users.

--LightDM for logins

--Adding Wine in the clover repository

Reply
#7
(03-26-2019, 07:12 PM)starrcade Wrote: I'll add to this:

--Detailed guide on converting from binary-clover to source; Changing this in cloveros_settings on a default install is one thing, but on a default install, updating the world set (Emerge -uavD @World) after changing from binary to source,  results in multiple perl-related errors/slot conflicts within portage, making it an uphill struggle for users.

--LightDM for logins

--Adding Wine in the clover repository


Code:
./cloveros_settings 5

idk I thought most DMs require a lot of shit get running
Code:
sudo emerge wine-any
T61 X9000 8gb 1680x1050
W500 X9100 8gb(dead)
T410 i7-640M 8gb 1440x900
T420 i7-2820QM 8gb 1920x1080
X230t i7-3520M 8gb 1336x768
W530 i7-3920XM 32gb 1920x1080
T440p i7-4810QM 8gb 1920x1080
W541 i7-4940XM 32gb 1920x1080

Reply
#8
(03-27-2019, 02:17 AM)tritonium Wrote:
(03-26-2019, 07:12 PM)starrcade Wrote: I'll add to this:

--Detailed guide on converting from binary-clover to source; Changing this in cloveros_settings on a default install is one thing, but on a default install, updating the world set (Emerge -uavD @World) after changing from binary to source,  results in multiple perl-related errors/slot conflicts within portage, making it an uphill struggle for users.

--LightDM for logins

--Adding Wine in the clover repository


Code:
./cloveros_settings 5

idk I thought most DMs require a lot of shit get running
Code:
sudo emerge wine-any

I have managed getting wine to run, by compiling from source.

The cloveros_settings script, however, after its changed to source, will throw this when -uavD @world is entered in;

Code:
* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

 (dev-libs/openssl-1.0.2r:0/0::gentoo, ebuild scheduled for merge) pulled in by
   >=dev-libs/openssl-1.0.2n:0=[-bindist] required by (net-libs/nodejs-8.12.0:0/0::gentoo, ebuild scheduled for merge)

 (dev-libs/libressl-2.8.3:0/46::gentoo, installed) pulled in by
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-misc/curl-7.64.0:0/0::gentoo, installed)
   dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
   dev-libs/libressl:0 required by (net-nds/openldap-2.4.45:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (dev-lang/rust-1.33.0:stable/1.33::gentoo, ebuild scheduled for merge)
   dev-libs/libressl:0/46= required by (net-libs/libtorrent-0.13.7-r1:0/0::gentoo, installed)
   dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (net-libs/nghttp2-1.33.0:0/1.14::gentoo, installed)
   dev-libs/libressl:0/46= required by (media-libs/opusfile-0.11:0/0::gentoo, installed)
   dev-libs/libressl:0/46= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, installed)
   dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
   dev-libs/libressl:0/46= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (www-client/w3m-0.5.3_p20180125:0/0::gentoo, ebuild scheduled for merge)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (dev-libs/cyrus-sasl-2.1.26-r10:2/2::gentoo, installed)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (app-arch/libarchive-3.3.1:0/13::gentoo, installed)
   dev-libs/libressl:0= required by (net-misc/wget-1.20.1:0/0::gentoo, installed)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-libs/nghttp2-1.33.0:0/1.14::gentoo, installed)
   dev-libs/libressl:= required by (net-libs/libtorrent-0.13.7-r1:0/0::gentoo, installed)
   dev-libs/libressl:= required by (dev-python/m2crypto-0.24.0:0/0::gentoo, ebuild scheduled for merge)
   dev-libs/libressl:0/46= required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
   dev-libs/libressl:0/46= required by (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed)
   dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (dev-libs/cyrus-sasl-2.1.26-r10:2/2::gentoo, installed)
   dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (media-video/ffmpeg-4.1.2:0/56.58.58::gentoo, installed)
   dev-libs/libressl:0/46= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
   dev-libs/libressl:= required by (dev-vcs/git-2.21.0:0/0::gentoo, ebuild scheduled for merge)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (net-libs/neon-0.30.2:0/27::gentoo, installed)
   dev-libs/libressl:0/46= required by (net-misc/wget-1.20.1:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (net-wireless/wpa_supplicant-2.6-r10:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, installed)
   dev-libs/libressl:0/46= required by (dev-qt/qtnetwork-5.11.3:5/5.11::libressl, installed)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (dev-lang/python-2.7.15:2.7/2.7::gentoo, installed)
   dev-libs/libressl:0= required by (dev-perl/Net-SSLeay-1.820.0:0/0::gentoo, installed)
   dev-libs/libressl:0/46=[abi_x86_64(-)] required by (media-video/ffmpeg-4.1.2:0/56.58.58::gentoo, installed)
   dev-libs/libressl:= required by (net-wireless/crda-3.18-r1:0/0::gentoo, installed)
   dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (net-libs/libssh2-1.8.0-r1:0/0::gentoo, ebuild scheduled for merge)
   dev-libs/libressl:0= required by (media-libs/opusfile-0.11:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (dev-lang/python-3.6.5:3.6/3.6m::gentoo, installed)
   dev-libs/libressl:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:=[abi_x86_64(-)]) required by (dev-libs/libevent-2.1.8:0/2.1-6::gentoo, installed)
   dev-libs/libressl required by (dev-lang/ruby-2.4.5:2.4/2.4::gentoo, ebuild scheduled for merge)
   dev-libs/libressl:0=[static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (net-misc/curl-7.64.0:0/0::gentoo, installed)
   dev-libs/libressl:0=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-libs/libressl:0=[abi_x86_64(-)]) required by (app-crypt/rhash-1.3.6-r1:0/0::gentoo, installed)
   dev-libs/libressl:0= required by (x11-base/xorg-server-1.20.3:0/1.20.3::gentoo, installed)
   dev-libs/libressl:0/46= required by (net-wireless/crda-3.18-r1:0/0::gentoo, installed)
   dev-libs/libressl:0/46= required by (net-misc/openssh-7.9_p1-r4:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages


The following mask changes are necessary to proceed:
(see "package.unmask" in the portage(5) man page for more details)
# required by www-client/chromium-73.0.3683.75::gentoo
# required by @selected
# required by @world (argument)
=net-libs/nodejs-8.12.0

The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by net-libs/nodejs-8.12.0::gentoo[ssl]
# required by www-client/chromium-73.0.3683.75::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/openssl-1.0.2r -bindist
In addition to that, there's also dozens of perl libraries that would install with this, that will probably cause conflicts in future world updates.

Reply
#9
If you read your error message, it shows that nodejs needs to be installed in order to install chromium, and nodejs needs to be unkeyworded with USE libressl set.

Both of which are done in the binhost's Portage settings.

./cloveros_settings.sh c

Reply
#10
Thanks, this actually worked.
Now onto getting LightDM working, my issue is with the bash script that shows up at everytime i login to pick a theme. Can I just remove that file and configure xfce & lightdm by way of the Gentoo wiki?

Reply
1 2 »

Currently browsing this topic
1 Guest(s)


« Next Oldest | Next Newest »


Forum Jump:


Current time: 11-11-2019, 08:47 PM